Code44free's Blog

Два слова о пользовательском аксессе

Posted in networking by code44free on Июнь 29, 2010

В современных design guides циска рекомендует на пользовательском аксессе использовать L3 с динамической маршрутизацией. Соответственно на распределение/ядро ставить шеститонники с VSS, пользователям стеки 3750.

Этот дизайн безусловно хорош. Нет петель, линки между VSS и 3750 собираем в port-channel и ни о чем не думаем. Если деньги считать не приходится, именно так и делаем. Или если деньги совсем считать не приходится делаем все нексусах

Но! Два 6506 с Sup720 будут стоить почти $200,000 по GPL плюс пять 3750 еще $45,000. При этом загрузка этого железа будет 5-10 процентов в пике

Решение на такое же количество портов с L2 дизайном, будет стоить значительно дешевле. Два 4506 c SupV $95,000, плюс пять с2960 еще $15,000. Итого разница в два с лишним раза $245,000 против $110,000.


Недостаток L2 дизайна: образуются петли, поэтому необходимо настраивать STP. Соответственно один из транков от аксесса к дистрибъюшену STP заблокирует и утилизироваться будет только половина пропускной полосы.

Но типичный профиль пользователей с аксессовского свитча это 3-5 мегабит трафика в сумме, т.е. даже один гигабитный транк не будет утилизоваться на 100%. Поэтому уполовинивание пропускной способности транков скорее придуманная проблема, чем реальная.

Настройка L2

Настраиваем на обоих 4506 VTP, заводим вланы:

vtp domain example.com
vtp mode server
!
vlan 10
name users_vlan_1
!
vlan 20
name users_vlan_2

настраиваем STP, для 10 влана этот 4506 будет первичным, для 20-го вторичным

spanning-tree mode pvst
spanning-tree uplinkfast
spanning-tree extend system-id
spanning-tree vlan 10 root primary
spanning-tree vlan 20 root secondary

на втором 4506 то же самое, только приорететы вланов зеркально наоборот

...
spanning-tree vlan 10 root secondary
spanning-tree vlan 20 root primary

Настраиваем транк между 4506, разрешаем на нем только нужные вланы

interface Port-Channel1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,20
switchport mode trunk

Настраиваем на 4506 транки на 2960

interface Port-Channel10
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

настраиваем на 4506 L3 интерфейсы и HSRP для шлюза. Выставляем HSRP priority такие же как и VTP primary/secondary. ИП адреса клиентам будут выдаваться внешними DHCP серверами (30.0.0.1, 30.0.0.2)

interface vlan 10
ip address 10.0.0.2 255.255.255.0
ip helper-address 30.0.0.1
ip helper-address 30.0.0.2
standby 10 ip 10.0.0.1
standby 10 priority 100
standby track Port-Channel1
!
interface vlan 20
ip address 20.0.0.2 255.255.255.0
ip helper-address 30.0.0.1
ip helper-address 30.0.0.2
standby 20 ip 20.0.0.1
standby 20 priority 200
standby track Port-Channel1


interface vlan 10
ip address 10.0.0.3 255.255.255.0
ip helper-address 30.0.0.1
ip helper-address 30.0.0.2
standby 10 ip 10.0.0.1
standby 10 priority 200
standby track Port-Channel1
!
interface vlan 20
ip address 20.0.0.3 255.255.255.0
ip helper-address 30.0.0.1
ip helper-address 30.0.0.2
standby 20 ip 20.0.0.1
standby 20 priority 100
standby track Port-Channel1

Настраиваем VTP на 2960

vtp mode client
vtp domain example.com

настраиваем транк на 4506

interface Port-Channel1
switchport mode trunk

заводим порты в соответствующие вланы

interface range FastEthernet0/1 - 23
switchport mode access
switchport access vlan 10
!
interface range FastEthernet0/24 - 48
switchport mode access
switchport access vlan 20

Реклама

Добавить комментарий

Заполните поля или щелкните по значку, чтобы оставить свой комментарий:

Логотип WordPress.com

Для комментария используется ваша учётная запись WordPress.com. Выход / Изменить )

Фотография Twitter

Для комментария используется ваша учётная запись Twitter. Выход / Изменить )

Фотография Facebook

Для комментария используется ваша учётная запись Facebook. Выход / Изменить )

Google+ photo

Для комментария используется ваша учётная запись Google+. Выход / Изменить )

Connecting to %s

%d такие блоггеры, как: