Code44free's Blog

Серверный аксесс

Posted in networking by code44free on Июль 22, 2010

Пример включения серверов из «экономного» дизайна предыдущего поста.

Для большинства инсталляций до 100 серверов, смысла выносить серверный аксесс из распределения нет. Особенно при использовании блейд серверов с встроенным в шасси свитчем. Поэтому такой дизайн серверного аксесса при своих явных недостатках, является экономически целесообразным.

В предложенной схеме одновременно трафик передается только по одному линку. На 4506 указаны маршруты с разной метрикой на лупбек сервера, через линки 192.168.х.х. На сервере указан дефолт с разными метриками через линки на свитчи. В итоге сервер доступен для клиентов по ИП лупбека, при пропадании основного линка, трафик пойдет по резервному с большей метрикой.




interface Port-channel1
description *** 4506 L3 aggregation ***
ip address 192.168.30.1 255.255.255.252
!
interface GigabitEthernet0/1
ip address 192.168.0.1 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
no cdp enable
!
ip route 10.0.0.1 255.255.255.255 192.168.0.2
ip route 10.0.0.1 255.255.255.255 192.168.30.2 20

второй

interface Port-channel1
description *** 4506 L3 aggregation ***
ip address 192.168.30.2 255.255.255.252
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
no cdp enable
!
ip route 10.0.0.1 255.255.255.255 192.168.10.2
ip route 10.0.0.1 255.255.255.255 192.168.30.1 20

на сервере присваиваем физическим интерфейсам соответствующие ИП адреса. Создаем лупбек с адресом 10.0.0.1/24. Прописываем следующую статическую маршрутизацию

0.0.0.0 0.0.0.0 192.168.0.1
0.0.0.0 0.0.0.0 192.168.10.1 metric 20

Реклама

Добавить комментарий

Заполните поля или щелкните по значку, чтобы оставить свой комментарий:

Логотип WordPress.com

Для комментария используется ваша учётная запись WordPress.com. Выход / Изменить )

Фотография Twitter

Для комментария используется ваша учётная запись Twitter. Выход / Изменить )

Фотография Facebook

Для комментария используется ваша учётная запись Facebook. Выход / Изменить )

Google+ photo

Для комментария используется ваша учётная запись Google+. Выход / Изменить )

Connecting to %s

%d такие блоггеры, как: